aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-07 18:59:06 -0400
committerDavid Robillard <d@drobilla.net>2022-07-17 18:13:53 -0400
commitd4a970f6962dda28133290194832b726b566ddab (patch)
treecfe9747042d55388705371a8ce95505ffb702470 /doc/meson.build
parent7f3a2651a3635232d94f7bf9ce23d6b575735732 (diff)
downloadlv2-d4a970f6962dda28133290194832b726b566ddab.tar.xz
Switch to meson build system
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..230211e
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,23 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+if doxygen.found()
+ aux_files = files(
+ 'pygments.css',
+ 'style.css'
+ )
+
+ foreach file : aux_files
+ configure_file(
+ input: file,
+ output: '@PLAINNAME@',
+ copy: true,
+ install_dir: lv2_docdir / 'aux')
+ endforeach
+
+ subdir('ns')
+
+ build_docs = true
+else
+ build_docs = false
+endif