aboutsummaryrefslogtreecommitdiffstats
path: root/doc/ns/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-07 18:59:06 -0400
committerDavid Robillard <d@drobilla.net>2022-07-17 18:13:53 -0400
commitd4a970f6962dda28133290194832b726b566ddab (patch)
treecfe9747042d55388705371a8ce95505ffb702470 /doc/ns/meson.build
parent7f3a2651a3635232d94f7bf9ce23d6b575735732 (diff)
downloadlv2-d4a970f6962dda28133290194832b726b566ddab.tar.xz
Switch to meson build system
Diffstat (limited to 'doc/ns/meson.build')
-rw-r--r--doc/ns/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/doc/ns/meson.build b/doc/ns/meson.build
new file mode 100644
index 0000000..26471b9
--- /dev/null
+++ b/doc/ns/meson.build
@@ -0,0 +1,33 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+config = configuration_data({'BASE': '/ns'})
+
+if get_option('online_docs')
+ htaccess = configure_file(
+ configuration: config,
+ input: files('..' / 'htaccess.in'),
+ install_dir: lv2_docdir / 'ns',
+ output: '.htaccess',
+ )
+endif
+
+subdir('ext')
+subdir('extensions')
+
+lv2_build_index = files(lv2_source_root / 'scripts' / 'lv2_build_index.py')
+
+index = custom_target(
+ 'index.html',
+ capture: true,
+ command: [
+ lv2_build_index,
+ '--lv2-version', meson.project_version(),
+ '--lv2-source-root', lv2_source_root,
+ '@INPUT@'
+ ],
+ input: spec_files,
+ install: true,
+ install_dir: lv2_docdir / 'ns',
+ output: 'index.html',
+)