aboutsummaryrefslogtreecommitdiffstats
path: root/doc/ns/extensions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/ns/extensions/meson.build')
-rw-r--r--doc/ns/extensions/meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/doc/ns/extensions/meson.build b/doc/ns/extensions/meson.build
index b54e3d2..5a25184 100644
--- a/doc/ns/extensions/meson.build
+++ b/doc/ns/extensions/meson.build
@@ -11,3 +11,38 @@ if get_option('online_docs')
output: '.htaccess',
)
endif
+
+spec_names = [
+ 'ui',
+ 'units',
+]
+
+if build_docs
+ foreach name : spec_names
+ spec_file = files(lv2_source_root / 'lv2' / name + '.lv2' / name + '.ttl')
+
+ custom_target(
+ name + '.html',
+ command: lv2specgen_command_prefix + [
+ '--docdir=../../c/html',
+ '--style-uri=../../style/style.css',
+ '@INPUT@',
+ '@OUTPUT@',
+ ],
+ depends: doc_deps,
+ input: spec_file,
+ install: true,
+ install_dir: lv2_docdir / 'ns' / 'extensions',
+ output: name + '.html',
+ )
+
+ if get_option('online_docs')
+ configure_file(
+ copy: true,
+ input: spec_file,
+ install_dir: lv2_docdir / 'ns' / 'ext',
+ output: '@PLAINNAME@',
+ )
+ endif
+ endforeach
+endif