aboutsummaryrefslogtreecommitdiffstats
path: root/doc/ns/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/ns/meson.build')
-rw-r--r--doc/ns/meson.build59
1 files changed, 53 insertions, 6 deletions
diff --git a/doc/ns/meson.build b/doc/ns/meson.build
index 26471b9..bb471c9 100644
--- a/doc/ns/meson.build
+++ b/doc/ns/meson.build
@@ -12,20 +12,67 @@ if get_option('online_docs')
)
endif
+######################
+# Core Documentation #
+######################
+
+if build_docs
+ spec_file = files(lv2_source_root / 'lv2' / 'core.lv2' / 'lv2core.ttl')
+
+ lv2_core_docs = custom_target(
+ 'lv2core.html',
+ command: lv2specgen_command_prefix + [
+ '--docdir=../c/html',
+ '--style-uri=../style/style.css',
+ '@INPUT@',
+ '@OUTPUT@',
+ ],
+ input: spec_file,
+ output: 'lv2core.html',
+ depends: doc_deps,
+ install: true,
+ install_dir: lv2_docdir / 'ns',
+ )
+
+ if get_option('online_docs')
+ configure_file(
+ copy: true,
+ input: spec_file,
+ install_dir: lv2_docdir / 'ns' / 'ext',
+ output: '@PLAINNAME@',
+ )
+ endif
+endif
+
+###########################
+# Extension Documentation #
+###########################
+
subdir('ext')
subdir('extensions')
+#########
+# Index #
+#########
+
lv2_build_index = files(lv2_source_root / 'scripts' / 'lv2_build_index.py')
+lv2_build_index_command = [
+ lv2_build_index,
+ '--lv2-version', meson.project_version(),
+ '--lv2-source-root', lv2_source_root,
+]
+
+if get_option('online_docs')
+ lv2_build_index_command += [
+ '--online',
+ ]
+endif
+
index = custom_target(
'index.html',
capture: true,
- command: [
- lv2_build_index,
- '--lv2-version', meson.project_version(),
- '--lv2-source-root', lv2_source_root,
- '@INPUT@'
- ],
+ command: lv2_build_index_command + ['@INPUT@'],
input: spec_files,
install: true,
install_dir: lv2_docdir / 'ns',