aboutsummaryrefslogtreecommitdiffstats
path: root/lv2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lv2/meson.build')
-rw-r--r--lv2/meson.build52
1 files changed, 0 insertions, 52 deletions
diff --git a/lv2/meson.build b/lv2/meson.build
deleted file mode 100644
index d8875eb..0000000
--- a/lv2/meson.build
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2022 David Robillard <d@drobilla.net>
-# SPDX-License-Identifier: CC0-1.0 OR ISC
-
-dirs = [
- 'atom',
- 'buf-size',
- 'core',
- 'data-access',
- 'dynmanifest',
- 'event',
- 'instance-access',
- 'log',
- 'midi',
- 'morph',
- 'options',
- 'parameters',
- 'patch',
- 'port-groups',
- 'port-props',
- 'presets',
- 'resize-port',
- 'state',
- 'time',
- 'ui',
- 'units',
- 'uri-map',
- 'urid',
- 'worker',
-]
-
-foreach dir : dirs
- subdir(dir)
-endforeach
-
-if not get_option('tests').disabled()
- check_python = pymod.find_installation('python3',
- modules: ['rdflib'],
- required: get_option('tests'))
-
- if check_python.found()
- lv2_check_specification = files(
- lv2_source_root / 'scripts' / 'lv2_check_specification.py'
- )
-
- foreach dir : dirs
- test(dir,
- lv2_check_specification,
- args: files(dir / 'manifest.ttl'),
- suite: ['spec'])
- endforeach
- endif
-endif