aboutsummaryrefslogtreecommitdiffstats
path: root/lv2/morph/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lv2/morph/meson.build')
-rw-r--r--lv2/morph/meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/lv2/morph/meson.build b/lv2/morph/meson.build
new file mode 100644
index 0000000..0742c03
--- /dev/null
+++ b/lv2/morph/meson.build
@@ -0,0 +1,40 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+name = 'morph'
+path = 'ns' / 'ext' / 'morph'
+
+morph_data = files(
+ 'morph.meta.ttl',
+ 'morph.ttl',
+ 'manifest.ttl',
+)
+
+headers = files(
+ 'morph.h',
+)
+
+# Install specification bundle
+install_data(morph_data, install_dir: lv2dir / name + '.lv2')
+install_headers(headers, subdir: 'lv2' / name)
+if get_option('old_headers')
+ install_headers(headers, subdir: 'lv2' / 'lv2plug.in' / path)
+endif
+
+# Build documentation
+if build_docs
+ lv2_morph_docs = custom_target(
+ name + '.html',
+ command: lv2specgen_command_prefix + [
+ '--docdir=../../html',
+ '--style-uri=../../aux/style.css',
+ '@INPUT@',
+ '@OUTPUT@',
+ ],
+ depends: doc_deps,
+ input: files('morph.ttl'),
+ install: true,
+ install_dir: lv2_docdir / 'ns' / 'ext',
+ output: name + '.html',
+ )
+endif