aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build27
1 files changed, 26 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 0b8339a..fe85e74 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -9,7 +9,7 @@
codespell = find_program('codespell', required: get_option('tests'))
if codespell.found()
ignore = [
- lv2_source_root / 'doc' / 'pygments.css',
+ lv2_source_root / 'doc' / 'style' / 'pygments.css',
lv2_source_root / 'lv2specgen' / 'DTD',
lv2_source_root / 'schemas.lv2' / 'doap.ttl',
]
@@ -108,3 +108,28 @@ endif
if is_variable('pylint') and pylint.found()
test('pylint', pylint, args: strict_python_scripts, suite: 'scripts')
endif
+
+##############
+# Unit Tests #
+##############
+
+test_names = [
+ 'atom',
+ 'forge_overflow',
+]
+
+# Build and run tests
+if not get_option('tests').disabled()
+ foreach test_name : test_names
+ test(
+ test_name,
+ executable(
+ test_name,
+ files('test_@0@.c'.format(test_name)),
+ c_args: c_suppressions,
+ dependencies: lv2_dep,
+ ),
+ suite: 'unit',
+ )
+ endforeach
+endif