aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-09-06 19:48:58 -0400
committerDavid Robillard <d@drobilla.net>2022-09-06 21:35:21 -0400
commit4b661ad6f1607afc30df5461756df6940ebd524e (patch)
tree5b934cc7bf189ca088dca9bb8f9abeeda62b9c7b /meson.build
parent453eae1c459af3e6284f4bfcfc65673932e38fb6 (diff)
downloadlv2-4b661ad6f1607afc30df5461756df6940ebd524e.tar.xz
Replace change history data with a plain text NEWS file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 0 insertions, 24 deletions
diff --git a/meson.build b/meson.build
index 178adf7..3e0fce5 100644
--- a/meson.build
+++ b/meson.build
@@ -345,31 +345,7 @@ subdir('util')
# Data and build tests
subdir('test')
-########
-# News #
-########
-
-lv2_write_news_py = find_program('scripts' / 'lv2_write_news.py')
-
-write_news_command = [
- lv2_write_news_py,
- '-t', 'http://lv2plug.in/ns/lv2',
- files(lv2_source_root / 'lv2' / 'core.lv2' / 'people.ttl'),
- files(lv2_source_root / 'lv2' / 'core.lv2' / 'meta.ttl'),
- spec_files,
-]
-
-custom_target(
- 'NEWS',
- capture: true,
- command: write_news_command,
- output: 'NEWS',
-)
-
if not meson.is_subproject()
- # Generate NEWS file from data in distribution archive
- meson.add_dist_script(write_news_command)
-
summary('Tests', not get_option('tests').disabled(), bool_yn: true)
summary('Documentation', build_docs, bool_yn: true)
summary('Prefix', get_option('prefix'), section: 'Paths')