aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/eg-sampler.lv2/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-23 16:08:07 -0400
committerDavid Robillard <d@drobilla.net>2023-09-23 17:09:41 -0400
commit31a8dbcca82a394f0dd236776692a8a53a031777 (patch)
tree6e6e09921441c8ba33de9b88ae2db7ba3f402f49 /plugins/eg-sampler.lv2/meson.build
parent7e8c1c7f96ea94869040fadd4550852b5ad67911 (diff)
downloadlv2-31a8dbcca82a394f0dd236776692a8a53a031777.tar.xz
Format meson.build files with muon
The less time wasted with manual code formatting, the better.
Diffstat (limited to 'plugins/eg-sampler.lv2/meson.build')
-rw-r--r--plugins/eg-sampler.lv2/meson.build28
1 files changed, 17 insertions, 11 deletions
diff --git a/plugins/eg-sampler.lv2/meson.build b/plugins/eg-sampler.lv2/meson.build
index 0916ff6..9700df2 100644
--- a/plugins/eg-sampler.lv2/meson.build
+++ b/plugins/eg-sampler.lv2/meson.build
@@ -6,18 +6,24 @@ ui_sources = files('sampler_ui.c')
bundle_name = 'eg-sampler.lv2'
data_filenames = ['manifest.ttl.in', 'sampler.ttl', 'click.wav']
-samplerate_dep = dependency('samplerate',
- version: '>= 0.1.0',
- required: get_option('plugins'))
+samplerate_dep = dependency(
+ 'samplerate',
+ required: get_option('plugins'),
+ version: '>= 0.1.0',
+)
-sndfile_dep = dependency('sndfile',
- version: '>= 1.0.0',
- required: get_option('plugins'))
+sndfile_dep = dependency(
+ 'sndfile',
+ required: get_option('plugins'),
+ version: '>= 1.0.0',
+)
-gtk2_dep = dependency('gtk+-2.0',
- include_type: 'system',
- required: get_option('plugins'),
- version: '>= 2.18.0')
+gtk2_dep = dependency(
+ 'gtk+-2.0',
+ include_type: 'system',
+ required: get_option('plugins'),
+ version: '>= 2.18.0',
+)
if samplerate_dep.found() and sndfile_dep.found()
module = shared_library(
@@ -57,7 +63,7 @@ if samplerate_dep.found() and sndfile_dep.found()
if cc.get_id() == 'gcc'
ui_suppressions += ['-Wno-strict-overflow']
endif
-
+
shared_library(
'sampler_ui',
ui_sources,