aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..230211e
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,23 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+if doxygen.found()
+ aux_files = files(
+ 'pygments.css',
+ 'style.css'
+ )
+
+ foreach file : aux_files
+ configure_file(
+ input: file,
+ output: '@PLAINNAME@',
+ copy: true,
+ install_dir: lv2_docdir / 'aux')
+ endforeach
+
+ subdir('ns')
+
+ build_docs = true
+else
+ build_docs = false
+endif