aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-15 20:51:53 -0400
committerDavid Robillard <d@drobilla.net>2023-05-15 20:51:53 -0400
commit52a96cec13bf2d541c42f8f398e7ea1387c6f56d (patch)
tree44f81e6ff16647356a584ef715222493402946f3 /meson.build
parent5dc503e6c79838eb93ad7cc2067b562ae0dfcce4 (diff)
downloadlv2-52a96cec13bf2d541c42f8f398e7ea1387c6f56d.tar.xz
Organize configuration summary
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 17 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index e56d08d..357b2be 100644
--- a/meson.build
+++ b/meson.build
@@ -348,9 +348,21 @@ if not get_option('tests').disabled()
endif
if not meson.is_subproject()
- summary('Tests', not get_option('tests').disabled(), bool_yn: true)
- summary('Documentation', build_docs, bool_yn: true)
- summary('Prefix', get_option('prefix'), section: 'Paths')
- summary('LV2 bundles', lv2dir, section: 'Paths')
- summary('Headers', get_option('prefix') / get_option('includedir'), section: 'Paths')
+ summary(
+ {
+ 'Tests': not get_option('tests').disabled(),
+ 'Documentation': build_docs,
+ },
+ bool_yn: true,
+ section: 'Components',
+ )
+
+ summary(
+ {
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'LV2 bundles': lv2dir,
+ },
+ section: 'Directories',
+ )
endif