aboutsummaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-09-08 18:38:40 -0400
committerDavid Robillard <d@drobilla.net>2022-09-08 19:03:49 -0400
commitb618c88c3a2e435846472c2b17c4df549b1a47f7 (patch)
treeccef81ef1ffe83e5c06661fe0c2fd54d56a8f8a5 /meson/suppressions/meson.build
parent8a7d896caf53bfb9f70cce71f0087c03d0d542d7 (diff)
downloadlv2-b618c88c3a2e435846472c2b17c4df549b1a47f7.tar.xz
Suppress Wbad-function-cast everywhere
Enough of this.
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index 70129a5..66510f9 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -17,6 +17,7 @@ if is_variable('cc')
if get_option('strict')
if cc.get_id() in ['clang', 'emscripten']
c_suppressions += [
+ '-Wno-bad-function-cast',
'-Wno-cast-align',
'-Wno-cast-qual',
'-Wno-declaration-after-statement',