aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/eg-sampler.lv2/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-08-31 18:30:11 -0400
committerDavid Robillard <d@drobilla.net>2022-08-31 18:30:11 -0400
commit6594c7c90901bb027b288363b8830d724581fbc3 (patch)
treebaf8c57c8cdd7f521d9cd5fb9ba73d55d144a3d1 /plugins/eg-sampler.lv2/meson.build
parent4a4c7cbaa444295b340c912e0f4a203b05be1fe8 (diff)
downloadlv2-6594c7c90901bb027b288363b8830d724581fbc3.tar.xz
Fix missing example plugin UI binaries
Diffstat (limited to 'plugins/eg-sampler.lv2/meson.build')
-rw-r--r--plugins/eg-sampler.lv2/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/plugins/eg-sampler.lv2/meson.build b/plugins/eg-sampler.lv2/meson.build
index 1283a8f..6cac920 100644
--- a/plugins/eg-sampler.lv2/meson.build
+++ b/plugins/eg-sampler.lv2/meson.build
@@ -2,6 +2,7 @@
# SPDX-License-Identifier: CC0-1.0 OR ISC
plugin_sources = files('sampler.c')
+ui_sources = files('sampler_ui.c')
bundle_name = 'eg-sampler.lv2'
data_filenames = ['manifest.ttl.in', 'sampler.ttl', 'click.wav']
@@ -13,6 +14,11 @@ sndfile_dep = dependency('sndfile',
version: '>= 1.0.0',
required: get_option('plugins'))
+gtk2_dep = dependency('gtk+-2.0',
+ include_type: 'system',
+ required: get_option('plugins'),
+ version: '>= 2.18.0')
+
if samplerate_dep.found() and sndfile_dep.found()
module = shared_library(
'sampler',
@@ -45,4 +51,17 @@ if samplerate_dep.found() and sndfile_dep.found()
)
endif
endforeach
+
+ if gtk2_dep.found()
+ shared_library(
+ 'sampler_ui',
+ ui_sources,
+ c_args: c_suppressions,
+ dependencies: [lv2_dep, gtk2_dep],
+ gnu_symbol_visibility: 'hidden',
+ install: true,
+ install_dir: lv2dir / bundle_name,
+ name_prefix: '',
+ )
+ endif
endif