aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-02-04 22:08:42 -0500
committerDavid Robillard <d@drobilla.net>2023-02-04 22:08:42 -0500
commitdbdbe3e518daf7b2f3f0e7587d8b2493b1d5a59e (patch)
treeabfc927bb311042b017c5d1ec7621251b453a219 /test/headers/meson.build
parent62d2e964e725bc8ca0841e9d532b65b083e7e027 (diff)
downloadlv2-dbdbe3e518daf7b2f3f0e7587d8b2493b1d5a59e.tar.xz
Fix clang and clang-tidy warnings in Windows
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index e0a2d76..cee8965 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -12,6 +12,12 @@ if get_option('strict')
'-Wno-padded',
]
+ if host_machine.system() == 'windows'
+ header_c_suppressions += [
+ '-Wno-format-nonliteral',
+ ]
+ endif
+
elif cc.get_id() == 'gcc'
header_c_suppressions += [
'-Wno-cast-align',