aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-10 14:51:34 -0500
committerDavid Robillard <d@drobilla.net>2022-12-11 13:15:02 -0500
commit86e5e821531ff563b7e4642aa792d9e0f3067557 (patch)
tree8c637653d8222471309f762eb36bc774f62a8fc2 /test/meson.build
parentd102b7df35d900d568e49e640a5331f283717737 (diff)
downloadlv2-86e5e821531ff563b7e4642aa792d9e0f3067557.tar.xz
Test headers for warnings more strictly
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index bd736fe..630fb0d 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -71,7 +71,7 @@ if is_variable('cpp')
test('cpp',
executable(
'test_build_cpp',
- files('test_build.cpp'),
+ files('cpp/test_build.cpp'),
cpp_args: cpp_suppressions,
dependencies: [lv2_dep],
),
@@ -112,6 +112,12 @@ if get_option('strict')
endif
endif
+###################
+# Header Warnings #
+###################
+
+subdir('headers')
+
##############
# Unit Tests #
##############