aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-11-19 17:49:14 -0500
committerDavid Robillard <d@drobilla.net>2022-11-19 17:49:14 -0500
commit8726bffa337e6374b04d0739df2812798b2c8858 (patch)
tree6cd1ddef24d06c6b5387f99f0c27cbc5bf28b1f9 /test/meson.build
parente9a02e4894a621c5f3889e3a8392ed4eb931293c (diff)
downloadlv2-8726bffa337e6374b04d0739df2812798b2c8858.tar.xz
Avoid test directory entirely if tests are disabled
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build24
1 files changed, 11 insertions, 13 deletions
diff --git a/test/meson.build b/test/meson.build
index 092499a..9f87232 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -122,17 +122,15 @@ test_names = [
]
# Build and run tests
-if not get_option('tests').disabled()
- foreach test_name : test_names
- test(
+foreach test_name : test_names
+ test(
+ test_name,
+ executable(
test_name,
- executable(
- test_name,
- files('test_@0@.c'.format(test_name)),
- c_args: c_suppressions,
- dependencies: lv2_dep,
- ),
- suite: 'unit',
- )
- endforeach
-endif
+ files('test_@0@.c'.format(test_name)),
+ c_args: c_suppressions,
+ dependencies: lv2_dep,
+ ),
+ suite: 'unit',
+ )
+endforeach