aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build59
1 files changed, 39 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index a202df5..aa9963f 100644
--- a/meson.build
+++ b/meson.build
@@ -1,15 +1,18 @@
# Copyright 2021-2022 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-project('lv2', ['c'],
- version: '1.18.10',
- license: 'ISC',
- meson_version: '>= 0.56.0',
- default_options: [
- 'b_ndebug=if-release',
- 'buildtype=release',
- 'c_std=c99',
- ])
+project(
+ 'lv2',
+ ['c'],
+ default_options: [
+ 'b_ndebug=if-release',
+ 'buildtype=release',
+ 'c_std=c99',
+ ],
+ license: 'ISC',
+ meson_version: '>= 0.56.0',
+ version: '1.18.11',
+)
lv2_docdir = get_option('datadir') / 'doc' / 'lv2'
lv2_source_root = meson.current_source_dir()
@@ -32,9 +35,6 @@ if not get_option('tests').disabled()
endif
# Set global warning flags
-if get_option('strict') and not meson.is_subproject()
- subdir('meson/warnings')
-endif
subdir('meson/suppressions')
##########################
@@ -81,6 +81,9 @@ lv2_dep = declare_dependency(
version: meson.project_version(),
)
+# Override pkg-config dependency for internal meson dependants
+meson.override_dependency('lv2', lv2_dep)
+
##################
# Specifications #
##################
@@ -185,8 +188,10 @@ check_python = pymod.find_installation(
required: get_option('tests'),
)
-if (check_python.found() and
- check_python.language_version().version_compare('<3.7'))
+if (
+ check_python.found()
+ and check_python.language_version().version_compare('<3.7')
+)
warning('Python 3.7 is required for tests')
check_python = disabler()
endif
@@ -343,12 +348,26 @@ endif
subdir('util')
# Data and build tests
-subdir('test')
+if not get_option('tests').disabled()
+ subdir('test')
+endif
if not meson.is_subproject()
- summary('Tests', not get_option('tests').disabled(), bool_yn: true)
- summary('Documentation', build_docs, bool_yn: true)
- summary('Prefix', get_option('prefix'), section: 'Paths')
- summary('LV2 bundles', lv2dir, section: 'Paths')
- summary('Headers', get_option('prefix') / get_option('includedir'), section: 'Paths')
+ summary(
+ {
+ 'Tests': not get_option('tests').disabled(),
+ 'Documentation': build_docs,
+ },
+ bool_yn: true,
+ section: 'Components',
+ )
+
+ summary(
+ {
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'LV2 bundles': lv2dir,
+ },
+ section: 'Directories',
+ )
endif