aboutsummaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build63
1 files changed, 49 insertions, 14 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index 66510f9..96ff2ab 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -1,11 +1,9 @@
-# Copyright 2020-2022 David Robillard <d@drobilla.net>
+# Copyright 2020-2023 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-# Project-specific warning suppressions.
-#
-# This should be used in conjunction with the generic "warnings" sibling that
-# enables all reasonable warnings for the compiler. It lives here just to keep
-# the top-level meson.build more readable.
+# Project-specific warning suppressions
+
+warning_level = get_option('warning_level')
#####
# C #
@@ -14,11 +12,12 @@
if is_variable('cc')
c_suppressions = []
- if get_option('strict')
+ if warning_level == 'everything'
if cc.get_id() in ['clang', 'emscripten']
c_suppressions += [
'-Wno-bad-function-cast',
'-Wno-cast-align',
+ '-Wno-cast-function-type-strict',
'-Wno-cast-qual',
'-Wno-declaration-after-statement',
'-Wno-documentation-unknown-command',
@@ -31,8 +30,21 @@ if is_variable('cc')
'-Wno-shorten-64-to-32',
'-Wno-sign-conversion',
'-Wno-switch-enum',
- '-Wno-unused-parameter',
+ '-Wno-unsafe-buffer-usage',
]
+
+ if not meson.is_cross_build()
+ c_suppressions += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
+ if host_machine.system() == 'windows'
+ c_suppressions += [
+ '-Wno-format-nonliteral',
+ ]
+ endif
+
elif cc.get_id() == 'gcc'
c_suppressions += [
'-Wno-bad-function-cast',
@@ -50,7 +62,6 @@ if is_variable('cc')
'-Wno-switch-enum',
'-Wno-unsuffixed-float-constants',
'-Wno-unused-const-variable',
- '-Wno-unused-parameter',
]
if target_machine.system() == 'windows'
@@ -62,7 +73,6 @@ if is_variable('cc')
elif cc.get_id() == 'msvc'
c_suppressions += [
'/wd4061', # enumerator in switch is not explicitly handled
- '/wd4100', # unreferenced formal parameter
'/wd4244', # conversion with possible loss of data
'/wd4267', # conversion from size_t to a smaller type
'/wd4310', # cast truncates constant value
@@ -79,6 +89,16 @@ if is_variable('cc')
endif
endif
+ if cc.get_id() in ['clang', 'emscripten']
+ c_suppressions += ['-Wno-unused-parameter']
+ elif cc.get_id() == 'gcc'
+ c_suppressions += ['-Wno-unused-parameter']
+ elif cc.get_id() == 'msvc'
+ c_suppressions += [
+ '/wd4100', # unreferenced formal parameter
+ ]
+ endif
+
c_suppressions = cc.get_supported_arguments(c_suppressions)
endif
@@ -89,19 +109,33 @@ endif
if is_variable('cpp')
cpp_suppressions = []
- if get_option('strict')
+ if warning_level == 'everything'
if cpp.get_id() in ['clang', 'emscripten']
- cpp_suppressions = [
+ cpp_suppressions += [
+ '-Wno-c++98-compat',
'-Wno-cast-align',
'-Wno-cast-qual',
'-Wno-documentation-unknown-command',
'-Wno-nullability-extension',
'-Wno-padded',
'-Wno-reserved-id-macro',
+ '-Wno-unsafe-buffer-usage',
]
+ if not meson.is_cross_build()
+ cpp_suppressions += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
+ if host_machine.system() == 'windows'
+ cpp_suppressions += [
+ '-Wno-format-nonliteral',
+ ]
+ endif
+
elif cpp.get_id() == 'gcc'
- cpp_suppressions = [
+ cpp_suppressions += [
'-Wno-cast-align',
'-Wno-cast-qual',
'-Wno-inline',
@@ -117,13 +151,14 @@ if is_variable('cpp')
endif
elif cpp.get_id() == 'msvc'
- cpp_suppressions = [
+ cpp_suppressions += [
'/wd4514', # unreferenced inline function has been removed
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
'/wd4820', # padding added after data member
'/wd5045', # will insert Spectre mitigation
+ '/wd5264', # const variable is not used
]
endif
endif