aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index 6e9ac7a..b1ec805 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -10,6 +10,7 @@ if get_option('warning_level') == 'everything'
'-Wno-cast-qual',
'-Wno-declaration-after-statement',
'-Wno-padded',
+ '-Wno-unsafe-buffer-usage',
]
if not meson.is_cross_build()
@@ -53,6 +54,8 @@ if cc.get_id() == 'clang'
]
endif
+header_c_suppressions = cc.get_supported_arguments(header_c_suppressions)
+
test(
'headers',
executable(