aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index 1d2162f..6e9ac7a 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -12,6 +12,12 @@ if get_option('warning_level') == 'everything'
'-Wno-padded',
]
+ if not meson.is_cross_build()
+ header_c_suppressions += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
+
if host_machine.system() == 'windows'
header_c_suppressions += [
'-Wno-format-nonliteral',