aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 4790a48..2fec667 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -36,7 +36,7 @@ if get_option('lint')
serdi = find_program(
'serdi',
required: get_option('tests'),
- version: '>= 0.31.5',
+ version: '>= 0.32.0',
)
native_build = (
not meson.is_cross_build()
@@ -157,6 +157,11 @@ test_names = [
'forge_overflow',
]
+atom_test_suppressions = []
+if cc.get_id() == 'gcc'
+ atom_test_suppressions += ['-Wno-stringop-overflow']
+endif
+
# Build and run tests
foreach test_name : test_names
test(
@@ -164,7 +169,7 @@ foreach test_name : test_names
executable(
test_name,
files('test_@0@.c'.format(test_name)),
- c_args: c_suppressions,
+ c_args: c_suppressions + atom_test_suppressions,
dependencies: [lv2_dep],
),
suite: 'unit',